ispmanager ошибка xml::libxml

Все таки репозиторий Atomic очень часто конфликтует с base-репозиторием.
При установке дополнения в ispmanager ( Настройки сервера -> Плагины )
получил такое сообщение:
ispmanager ошибка xml::libxml

Для работы выбранного плагина необходимо установить следующие дополнительные модули:
XML::LibXML
Внимание! Установка модулей может занять довольно продолжительное время

В консоли пробуем установить недостающее дополнение к perl:

yum install perl-XML-LibXML

и получаем

Resolving Dependencies
--> Running transaction check
---> Package perl-XML-LibXML.x86_64 1:1.70-5.el6 will be installed
--> Processing Dependency: perl(XML::SAX::DocumentLocator) for package: 1:perl-XML-LibXML-1.70-5.el6.x86_64
--> Running transaction check
---> Package perl-XML-SAX.noarch 0:0.96-7.el6 will be installed
--> Processing Conflict: perl-XML-SAX-Base-1.08-10_4.el6.noarch conflicts perl-XML-SAX < 0.99
--> Finished Dependency Resolution
Error: perl-XML-SAX-Base conflicts with perl-XML-SAX-0.96-7.el6.noarch
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

конфликт perl-XML-SAX-Base и perl-XML-SAX.
Посмотреть из какого репозитория модуль perl-XML-SAX-Base:

yum info perl-XML-SAX-Base
Installed Packages
Name        : perl-XML-SAX-Base
Arch        : noarch
Version     : 1.08
Release     : 10_4.el6
Size        : 167 k
Repo        : installed
From repo   : atrpms
Summary     : Base class SAX Drivers and Filters
URL         : //search.cpan.org/~khampton/XML-SAX-Base-1.08/
License     : Artistic
Description : This module has a very simple task - to be a base class for
            : PerlSAX drivers and filters. It's default behaviour is to pass the
            : input directly to the output unchanged. It can be useful to use
            : this module as a base class so you don't have to, for example,
            : implement the characters() callback.

perl-XML-SAX-Base из atrpms (Atomic), perl-XML-SAX из base репозитория.
Видимо perl-XML-SAX-Base ранее подцепился с чем то другим.
Исправляем:

yum remove perl-XML-SAX-Base
#Removed:
#  perl-XML-SAX-Base.noarch 0:1.08-10_4.el6
#Complete!
yum install perl-XML-SAX
#Installed:
#  perl-XML-SAX.noarch 0:0.96-7.el6
#Dependency Installed:
#  perl-XML-LibXML.x86_64 1:1.70-5.el6
#Complete!

Необходимый XML::LibXML притянулся автоматом.
В ispmanager идем в плагины и устанавливаем необходимый уже без ошибок :-)

Скажите свое мнение

ваш email не публикуется. обязательно *

;-) :yawn: :whew: :toivo: :tmi: :time: :thinking: :talking: :sweating: :swear: :sun: :star: :smoke: :smirk: :sleepy: :skype: :shock: :shake: :rofl: :rain: :punch: :puke: :poolparty: :pizza: :phone: :party: :oops: :nod: :no: :ninja: :neutral: :nerd: :music: :muscle: :mrgreen: :movie: :mooning: :mmm: :middlefinger: :makeup: :mail: :mad: :lol: :lipssealed: :kiss: :itwashtme: :inlove: :idea: :hi: :heidy: :heart: :headbang: :happy: :handshake: :giggle: :fubar: :flower: :evilgrin: :emo: :dull: :drunk: :drink: :doh: :devil: :dance: :cry: :cool: :coffie: :clapping: :cash: :call: :cake: :bug: :brokenheart: :bow: :blush: :beer: :bear: :bandit: :arrow: :angry: :angel: :^) :???: :?: :-| :-o :-P :-D :-) :-( :!:

 

*

code

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.