Посты про “yum”

centos YumRepo Error


Небольшая проблема при установке старой centos возникла:

yum update
#Loaded plugins: fastestmirror, security
#Determining fastest mirrors
#YumRepo Error: All mirror URLs are not using ftp, http[s] or file.
# Eg. Invalid release/
#removing mirrorlist with no valid mirrors: #/var/cache/yum/base/mirrorlist.txt
#Error: Cannot find a valid baseurl for repo: base

(далее…) «centos YumRepo Error»» class=»more-link»>далее «centos YumRepo Error»

atd[*****]: File a*********** is in wrong format — aborting


Обратился клиент с проблемой: непонятным образом стало заканчиваться место на его ВПС.
При первоначальном осмотре выявилась причина «поедания» места — системный лог:

/var/log/messages

и его архивы, которые заняли все доступное пространство.
Распухли они от одной ошибки, которая тысячами валилась:

atd[*****]: File a*********** is in wrong format - aborting

(далее…) «atd[*****]: File a*********** is in wrong format — aborting»» class=»more-link»>далее «atd[*****]: File a*********** is in wrong format — aborting»

configure: error: WARNING:


Очень простая ошибка на unix-подобных системах. Не установлен GCC (GNU Compiler Collection) – стандартный компилятор.

error: no acceptable C compiler found in $PATH
error: memcache support requires ZLIB. Use --with-zlib-dir=<dir> to specify prefix where ZLIB include and library are located
WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.
</dir>

(далее…) «configure: error: WARNING:»» class=»more-link»>далее «configure: error: WARNING:»

centos ошибка unfinished transactions remaining


При установке необходимого пакета вылезло сообщение:

There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
The program yum-complete-transaction is found in the yum-utils package.

(далее…) «centos ошибка unfinished transactions remaining»» class=»more-link»>далее «centos ошибка unfinished transactions remaining»

небольшие моменты centos


Для большинства сайтов и движков большая проблема — php 5.4, в котором удалены некоторые устаревшие функции. Чтобы yum не устанавливал эту версию добавьте в настройки репозиториев (лежат тут /etc/yum.repos.d/название.repo):

exclude = php*5.4*

(далее…) «небольшие моменты centos»» class=»more-link»>далее «небольшие моменты centos»

установка yum


centos

cd /tmp
mkdir yum
cd yum

(далее…) «установка yum»» class=»more-link»>далее «установка yum»